Jump to content

Wax not releasing from clamshells


Recommended Posts

I'm new to wax melts making and am having problems getting the wax to come out of the clamshells after setting. I have tried IGI 4794 and IGI 4786. I've tried different pouring temperatures, but they won't release. And when I say they won't release, I mean it almost takes an act of god to get them out. I also work with IGI 4636 and though about adding some of that to see if it made any difference, but thought I'd seek out some help here first. Any suggestions are greatly appreciated. Thank you.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...