Jump to content

My lotion has mold!!!!!


Michi
 Share

Recommended Posts

I can't believe it!! I just went to sniff some lotion I had made at Christmas time, and I opened and just about hoarked, there was a big ol' green fuzzy patch on top!! :(

This was a base I had, and I was assured that it already had a preservative in it.

The bad thing is, I gave a bunch of this out to people at christmas and such, and now I'm worried about them getting moldy too. :(

I'm sooo worried and embarrassed now. I mean who would want to buy products from me if their lotion turns moldy????? :embarasse

Link to comment
Share on other sites

Sterilzation was a BIG yes, bleached myself to death baby!! LOL :D

Yes, I guess I will contact them, it's funny though I've been making that same base for a while now and it never did that before, so I wonder if something funky just got into that particular batch??

The bad part is, I gave out the other half of that batch to my hubby's cousin for Christmas. :embarasse

Link to comment
Share on other sites

It's in a jar, but this jar that I opened yesterday has not been used, it's just been stored since I made it.

I'm thinkin' something funky just got in there when I made it or something, b/c none of my other lotions or creams (same base) have done this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...